Fedora 8 32 bit (Full update) sound problem.

The sound on the desktop works perfectly.
Running an example shows the following error.

[edin@INTEL-E6850 Asteroids] python Tut-Asteroids.py DirectStart: Starting the game. Warning: DirectNotify: category 'Interval' already exists Known pipe types: glxGraphicsPipe (all display modules loaded.) python: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed. Aborted [edin@INTEL-E6850 Asteroids]



On linux, Panda3D’s audio is a thin wrapper around a sound library called fmod. That error message isn’t coming from inside Panda3D - it might be coming from fmod, or it might be coming from your sound driver.

So, you could probably spend hours trying to fix this, but I don’t think it’s worth the effort. Here’s why. Fmod isn’t free software anyway. I’ve been trying to phase out fmod and replace it entirely with OpenAL, which is free software. I have not been able to do that yet, since last time I checked about six months ago, OpenAL was too buggy under Linux. But the sense I got at the time was that the OpenAL developers were working very hard on the linux version. For all I know, they may have fixed OpenAL by now. What I need to do is try building Panda3D with the latest verson of OpenAL. This may simply cause your problem to disappear. So if I were you, I’d just wait for that.

As a stopgap until then, you can just disable audio. Do this by changing the line in the Panda3D config file that says ‘fmod_audio’ to ‘null_audio’.

I use openAL on my linux it appears fine. Although a bit slow.

I disable the sound.

Thank you