Fedora 11 display(error) with Intel 945GME [Solved]

I’m getting the following error messages when running for example the Roaming Ralph sample:


The sample loads fine and runs fine until I start interacting with it ie. moving ralph. Then after about 3-5 seconds the app gets stuck and spews the messages.

Here’s the same with “notify-level-display debug” in Config.Prc:


I’m using the latest Panda version (panda3d-1.6.2-3.1.i386.rpm for Fedora 11). I did not have this problem with Fedora 10.

Any ideas what I could try to fix this?

I tried the solutions in the following threads but they did not solve the problem for me:



Thanks in advance!

Hm, I didn’t see this one before. Driver bug, likely?

The issue occurs in the function where it tries to apply a vertex buffer. Can you try putting this in your Config.prc file:

vertex-buffers #f

Thank you, that fixed the problem! :slight_smile:

So the issue is that the driver thinks it can handle vertex buffers where it cannot or what?

That’s a possibility. Or it’s a driver bug.
Or Panda is doing something wrong that most drivers just allow anyways, except for yours.

I can’t really investigate what the cause of the problem is without being able to reproduce this issue myself.