Feature-Tutorials--Shadows BUG!

I get:
“Shadow Demo: Video driver reports that depth textures are not supported.”
and then in the command line i get:
me@lapper:~$ glxinfo | grep depth
GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,

full version: dpaste.com/hold/15690/

any way i can troubleshoot the problem?

Hm. I can’t imagine what the deal is there. This is from the C++ code:

_supports_depth_texture =
has_extension(“GL_ARB_depth_texture”) || is_at_least_version(1, 4);

Pretty darn simple. And the function getSupportsDepthTexture() is just returning the value of that variable. So it’s hard to guess what’s going wrong. So do this: in your config.prc file, add this:

notify-level-glgsg debug

This will cause panda to dump an unreasonable amount of information. Try capturing that to a file, and see what extensions panda is reporting.

does it need 1.4 from the code check? I am running 32 bit feisty. on a MOBILITY RADEON X600 SE using ATI Technologies Inc. closed source drivers.

any thing else i can do?

It shouldn’t need 1.4. That’s a logical “or” operator there… so I can’t imagine what’s going on.

I’m going to puzzle over this some more.

thank you very much i would love to get fast shadows to work :slight_smile:

Same error, but when I use the algorithm itself in my own app it works good.

So I see that treeform was using a mobility radeon X600… what about you, pro-rsoft?

pro-rsoft, can you post your app that works? or is it too complex? It might have some thing todo with the fact that the sample is initializing some thing that conflicts with the depth texture.

Here you go, just our lighting module, which works fine:
heartseed.svn.sourceforge.net/vi … iew=markup
This module lights everything that is parented to the builtin renderL.

But when running the Shadow example, sorry, no depth texture error, but this:
“Driver cannot create an offscreen buffer.”
Josh, my card is a GeForce FX 5200… my debug output is in this post.
It’s weird that my own code works, AND about a month ago I got your Shadow Example from CVS, and it worked for me too on 1.3.2.

I can’t for the life of me figure out what’s going on here. One minute it says it has depth textures, the next minute it doesn’t.

You could try compiling panda, then running it under the C++ debugger to see what’s going on. It’s actually not very hard to do. If you’re up for it, just say so.

I join this thread for not making another, when i run the shadow demo panda tell me :

And when i quit the app he said me :

A screenshot of what looks the shadow demo on my computer.

I don’t know if it’s the good render, but when i modify the bias value and the light source nothing appended.
Can somebody post a good render of the sample ?

if it can help, my graphic card is :