Failed to import qedit.h

Just tried building a CVS snapshot from earlier today and in the WebcamVideoDS compilation the build fails because qedit.h couldn’t be found.

Putzed around the webs and found that it’s no longer included in the Windows 7.0 SDK (which is the only one I seem to able to use even if I tell VS2008 to use 6.1).

Anyone either have the file or know what package to skip to prevent compiling that part of the engine? Trying to build without DirectX support as a workaround for now but I’d rather have it just in case.

Thanks

~Andrew

There are three options you could take:

  • Install the professional version of VS 2008.
  • Compile with --no-directcam.
  • As the manual page about compiling Panda3D on Windows states, you can use this version of the SDK:
    microsoft.com/downloads/deta … laylang=en

Ok no-directcam that’s what I was looking for. I think it’s honestly a weird SDK thing because I have VS2008 pro, plus I have a number of Windows SDK versions, including Server 2003 R2. Sadly, having a ton of SDK versions installed at once is probably the issue. I think it defaults to the highest one even if you pick a lower version. Tried using the platform SDK registration utility, but that didn’t seem to do much.

I was reading a bit more and it looked like qedit.h may be included in the DirectX SDK as well, not sure on that though. Will keep digging. Thanks rdb.