egg files created from 3D Max 7

Hi experts!

I have a problem creating 3D models for a Panda game.

It is not possible for me to find the individual geomnodes in the created egg-file. I know that i can use the egg-optchar program but it doesn’t seem to work.

Here is an example of how i use the egg-optchar program:

egg-optchar -inplace -flag house1=h1,house2=h2,house3=h3 Environment2.egg

After this is done i can only see h3 in my sceneEditor / game.
What is the problem? :unamused:

wouldnt it be easier to just export your scene directly from 3dsmax using the plugin? That what I do, and it works fine…

try this:

egg-optchar -inplace -flag house1=h1 -flag house2=h2 -flag house3=h3 Environment2.egg

russ>> Thank you it worked. Now i get all the nodes. So i can conclude that there need to be a -flag in front of every node in the command line.

yellow>> That’s the thing im doing. It isn’t enougt just to export the scene to an egg. I need to do the trick russ has explained to get in touch with the objects from python. The problem is related to working with collisions.

Thanks again!!