Don't get bump maps to work Blender & Yabee exporter

Dear fellow Panda users,

I’m recently trying to use the Panda 3d engine v.1.9.1 and I make models using Blender 2.76 with Yabee exporter v13.0.

So I’ve made a grid primitive for an aircraft runway on which I want to apply a diffuse texture and a normal map.

In my egg model I see the following references to the normal map:

<Texture> Texture.004 {
  "tex/runway_n.png"
  <Scalar> wrap { repeat }
  <Scalar> minfilter { linear_mipmap_linear }
  <Scalar> magfilter { linear_mipmap_linear }
  <Scalar> envtype { normal }
<Polygon> {
    <Normal> { 0 0 1 }
    <TRef> { Texture.001 }
    <TRef> { Texture.004 }
    <MRef> { Material.004 }
    <VertexRef> { 0 2 3 1 <Ref> { Grid } }

Additionally, the UVs under Vertex show tangents and binormals. In blender the maps are displayed correctly (GLSL selected). In Panda only the diffuse map is visible. I’ve set TBS generation to “Panda”. There is an option to select Blender aswell, choosing this returns an error.

In my .py file I’ve added lights (ambient & directional) and I’ve added the render.setShaderAuto()

Any help is greatly appreciated, trying to get this to work for days!

Perhaps you could share the texture, and perhaps also the .egg files?

Dear rdb,

Attached are the files, if you need anything else let me know,

Thanks



runway.egg (1.82 KB)

Seems to work fine for me, when I pview the model and hit L to enable a light source and P to enable the shader generator:
rdb.name/2016-02-08-230442_573x1030_scrot.png
(used a white texture as stand-in for the diffuse texture)

Perhaps your call to setShaderAuto is being overridden somewhere? Or your lights aren’t being applied properly? There’s not enough information to go on here.

Aaah the ligthing wasn’t set in the right direction!
Thanks a lot for your help and time