Disable screensaver while using joystick (and wxWindows)

Hi all!

Do you have any ideas on how to best avoid the screensaver activating when you play a game using only the joystick? I suspect that this is not a problem when running fullscreen so maybe I should add that I’m running Panda3D inside of a wxWindows window.

/Daniel

I don’t have any experience with that. Maybe there’s a Windows call that disables the screensaver?

David

On Vista and later, you can call this command:

presentationsettings /start

This will enable “Presentation Mode”, which by default disables the screen saver and notifications. People can set it not to disable the screen saver though. So it’s probably not an ideal solution.

Maybe you can generate mouse or keyboard activity once every so often?