Creating a start point

I have an egg file and I’m trying to create a dummy point to use as a reference to position my camera at the start (using 3ds max)

What i’ve tried to do was to create a “point” helper at first to see if it would export the helper object, and I tried to export a dummy object to use as a reference and neither of those even were seen by the exporter. Then I tried to create a plane and delet all the verts except for one and export that, but the exporter decided to disregard any information besides the object name. So finally I just decided to make a box and reference it’s starting point.

But my problem is when I try to use:

cameraStart = levelOneBase.find("**/camera_Start").getPos()

it gives me an error saying:
!is_empty() at line 1253 of panda/src/pgraph/nodePath.cxx

I think that maybe I’m not locating my object quite right.

Any ideas?

the !is_empty line means that the nodepath returned from find() was empty (or level node is but thats unlikely in your case). which means the node you searched was not found.
you may want to check the search arguments and make sure the node exists.

Well, I’m not sure how to structure searches in the egg files. I open the file and know that what I’m searching for exists, but I think I might just have the wrong structure.

I took the point out of the roaming ralph file and pasted it into my own egg file and panda found and could use that point with no problem. What I have noticed is that my object I’m looking for is within another object it seems like. In other words I feel as though I’d have to search like: find("**/character/camera_Start") to get to it, but that doesn’t work either.

Thanks for the help I appreciate it.

Try this :

That gives me:

Character character
Geomnode (3 geoms: blah-nonesense)
ModelNode start_point T:m(position 5,4,-5)

The “start_point” is the thing I copied from roaming ralph. But I don’t see my box I made. I wish I just knew how to make those model nodes export in a fashion identical to roaming ralphs with the 3ds Max exporter.

Is it supposed to be a static or animated model ?
Maybe you chose the wrong export type.

Static model…

And I tried all the export types, and all the different types of point referencing that 3ds max has… :confused: