Crash when using DirectX


since the perfotmance of Airblade was pretty bad on my pc, i switched to pandadx8 in the Configrc. But after that, almost everytime I start a Panda application, it crashes the whole system (w2k) and I have to reboot :frowning:. I thought it might be a problem that I am using DirectX 9.0b - so I tried to exchange the “pandadx8” line with “pandadx9”. But that doesn’t seem to work.

Is there a way to get Panda running with DirectX 9 on a w2k system?


I also tried to run Panda3d using DirectX (under Windows XP, DirectX 9, Nvidia Geforce2Ti) and couldn’t get it to work. The app would start and then quickly quit (but didn’t crash my computer). Any ideas on this?

Panda does run well in DirectX 8.1 mode, which is a subset of the Direct X 9.0 runtime. Most people should have success with “pandadx8” specified in your Configrc file.

That being said, the newest drivers from nVidia do not support DirectX 8.1; nVidia has decided to cut corners by dropping support for versions of DirectX other than 9.0. If you have an nVidia card with a driver newer than May 14, 2003 then you may have problems running with pandadx9; you should use OpenGL (“pandagl”) instead; or you can downgrade to an older version of the driver (version 44.03 was the last that worked well with DX8).

We are in the process of adding native support for DX9 now; when this is in place you will be able to specify “pandadx9”.