couldn´t import xml file when change server [solved]

Oops … i´m here again.

I woke up today very happy with my app.p3d. Then i think … “Why not put it on web?”.

My old packs are in localhost is a apache run in my machine (wow) :wink:

Then i repack my packages to my server doutorpalhaco.com/pandaweb02/bb_pack/ got a contents.xml.

Then i re-packp3d in my app.p3d again to call the packages from my server.

Then the problem begin…
Outputs …

packp3d -S ../certificados/germano.pem -o ../outputs/Application02/Application02.p3d -d ../Application02/ -m WMain.py -r bbGMaker,,http://www.doutorpalhaco.com/pandaweb02/bb_pack/ -r fmod -r assets,,http://www.doutorpalhaco.com/pandaweb02/bb_pack/    
:PackageInfo: Removing usage.xml
:PackageInfo: Removing usage.xml
:HostInfo: Downloading contents file [ http://www.doutorpalhaco.com/pandaweb02/bb_pack/contents.xml?1284576437 ]

:AppRunner: Freshening http://www.doutorpalhaco.com/pandaweb02/bb_pack/bbGMaker/bbGMaker.import.xml
:AppRunner: http://www.doutorpalhaco.com/pandaweb02/bb_pack/bbGMaker/bbGMaker.import.xml is still no good after downloading.
Traceback (most recent call last):
  File "C:\panda3d-1.7.0\built_cmu\direct\showbase\Messenger.py", line 352, in __taskChainDispatch
  File "C:\panda3d-1.7.0\built_cmu\direct\showbase\Messenger.py", line 410, in __dispatch
  File "C:\panda3d-1.7.0\built_cmu\direct\p3d\AppRunner.py", line 493, in __startIfReady
  File "VFSImporter", line 153, in load_module
  File "/root/pandaworker/panda3d-1.7.0/built_cmu/direct/p3d/packp3d.py", line 219, in <module>
  File "/root/pandaworker/panda3d-1.7.0/built_cmu/direct/p3d/packp3d.py", line 202, in makePackedApp
  File "/root/pandaworker/panda3d-1.7.0/built_cmu/direct/p3d/Packager.py", line 2646, in do_require
  File "/root/pandaworker/panda3d-1.7.0/built_cmu/direct/p3d/Packager.py", line 2672, in requirePackagesNamed
  File "/root/pandaworker/panda3d-1.7.0/built_cmu/direct/p3d/Packager.py", line 2396, in findPackage
  File "/root/pandaworker/panda3d-1.7.0/built_cmu/direct/p3d/Packager.py", line 2501, in __findPackageOnHost
  File "C:\panda3d-1.7.0\built_cmu\direct\directnotify\Notifier.py", line 132, in error
StandardError: Couldn't download import file.
:task(error): Exception occurred in PythonTask Messenger-default

bbGMaker.import.xml is still no good after downloading.

So why? I didn´t any manual change in this file. I re-ppackage it to refer doutorpalhaco.com/pandaweb02/bb_pack/.
:angry:

The curious one is if i re-ppackage and re-packp3d to localhost it works …

Thanx

It says that the copy of bbGMaker.import.xml provided by your server doesn’t match the md5 hash for that file that is listed in the contents.xml provided by your server. In other words, the bbGMaker.import.xml file has been modified from its original contents.

If I were to guess, I’d suspect the modification is due to the end-of-line characters getting converted. Often, when you upload files to a server, you inadvertently convert the file to MS-DOS or Unix end-of-line convention. Make sure that whatever process you use does not modify the files in any way–make sure you treat the xml files as binary files, not text files. Also make sure that the server itself doesn’t adjust the xml files when it serves them. (Some smart servers might attempt to inject code into the xml files it offers for some reason.)

David

Yes, looking at your xml files as offered by your server now, I see that indeed your bbGMaker.import.xml file is being offered with Unix end-of-line characters. But the original file had Windows end-of-line characters, so it must have been changed somewhere along the way–either by your upload process, or by the server itself.

David

I´ll work on that. thanx +++++

Yeah david … that´s it.
I know i must pay a lot of beers 2 you someday :smiley:
Cheers

Sorry for redigging/hjacking this topic but I stumpled over the same issue but I cannot manage to perserve the lineending. Is there a way to tell ppackage to create the xml files with unix style endings on windows?

I don’t think there’s an option to change this. I guess we could add an option, but–really? You can’t upload the file to your server without changing it in the process? How do you upload binary files?

David