Converting issues with animated objects.

I am new with panda3d and as an 3d artist dont i really know too much about the world of programming. But enoght about me and why i am adding this topic.

I have tried to convert 3d objects into panda3d now for a day, i manage to put in a static mesh in DXF format without any problem but when i come to animated and rigged objects all the difficult and unpleasant issues come into my way. My primary software i use is Lightwave and i convert them from .lws to direct x with polytrans.

  1. Direct X import issue
    x2egg converter how comes along with panda dont work at all with my .x objects, after i read a bit into this forum it could be explained that the converter might not work yet in this 1.5.2 version. x2egg told me " too many data elements in structure" on every .x i tried to convert.

  2. Maya Learning ED
    I did hear a rumor, i say rumor because i didnt found out much about it. It was about Maya Learning Edition, that it could convert to .egg. Could that be possible? I think its not might work for me unless i buy the commersial license of maya too someday, anyway i am curious and it could be a tempory solution while learning.

  3. Chicken exporter with Blender.
    So then .x didnt work for me, i did try to find another solution and becouse i heard from this forum alot about the chicken script to blender, did i try too get along with that application. But Blender havent any .x importer that could bring in the animation. I found out that the biovision exporter in polytrans should work and Blender can import .bhv too. The only problem now is that it demand another kind of setup to the rig then for .lws to .x and its also only a converter for the rig itself with animations. So this would work but it takes alot of times to learn how to use it and then needs alot of steps with compileing the objects. I do not prefere this method but so far it seems to be my only solution for animated objects.

My thoughts about panda 3D
Panda3D took me by storm and i havent encounter any other 3d programming tool that had rise my intresst like that before even if ive tried some other tools before. But then again in this world of 3D, is the compability of animated 3d objects kind of disturbing. I wish the x2egg would work for me someday.

maybe you can try older panda versions to convert your x files to egg. back in 1.4.0 the x2egg converted was known to work quite well.

I have not tried yet with 1.5 versions.

But .X conversion was working real fine with 1.4 before.

However i’ve met some discrepancies with various tools exporter

  1. first be sure to export to version 8 of direct X file format in text form.
  2. preview your .X file with the DirectX 8 Sdk meshviewer.
  3. Check that your X file is consistent in term of braces (right opening/closing of braces) and bones/textures naming convention (check for special characters in group/bones/textures names)

As far as I know, the X importer should be working fine in 1.5.2. If it is not, there might be a genuine problem with your X files–suggest you follow Manakel’s advice.

David

Thanks for the great advice, i think the problem is that my .X files are probably in Direct x9 and that makes it defect, i will also follow Manakel other advices too and will return here soon and tell whats happend.

Maybe this is a minor extension to the X file syntax that lightwave puts in there? If so, we might be able to adapt the X-file parser to accept this extension. Go ahead and send us an X-file that doesn’t parse, and we can play with it.

I didnt made it, still the same issue with the x2egg exporter. Probably me being stupid but anyway, i have here put out three horrible .x test objects and one readme file about them in a .zip HERE, thanks once again for all the helping hands.