compress-tex produces white blank pngs with ATI Hd5450?


When I use turn on auto texture compression using “compress-tex”, I get completely white blank textures with a ATI HD 5450 card. (The starting textures are non-power-of-2 png files.) Everything seems to work fine on a Nvidia GTX 260. Has anybody else run into this problem before?

Haven’t seen that before. Have you tried it with power-of-2 textures instead to see if that makes a difference? Are these textures mipmapped or not, and if so have you tried disabling mipmapping? I’m not suggesting to do these things as a solution, just to gain another data point. It’s also worth asking whether you are sure you have the most current driver installed. What operating system are you running?

I assume by “compress-tex” you mean “compressed-textures”. One additional experiment to try is “driver-compress-textures 1”, which means to ask your graphics driver to do all of the compression work, which might help if the problem is some kind of strange incompatibility in the way your driver implements compression.


Hi David,

I traced down the culprit to setting the texture's mipmap mode. 

tex.setMinfilter( Texture.FTLinearMipmapLinear )

Enabling this mipmap causes all the auto compressed textures to become white. I’ve tried this on a WinXP XP 32-bit system and a Win 7 32bit system. Both systems were using an ATI/AMD 5450 card.

I don't have access to another ATI card right now so I'm not sure if its specific to the 5450 exactly. I'll try to get my hands on another ATI chipset, but it might take a while..

You could try setting “driver-generate-mipmaps 1” to ask the driver to generate mipmaps. Perhaps that would work.