compiling under Ubuntu

I seem to be having a bit of trouble compiling the samples under ubuntu. I’m using the command

alex@origins:/usr/share/panda3d/samples/Sample-Programs–Fireflies$ python

and it gives me the error

DirectStart: Starting the game.
Warning: DirectNotify: category ‘Interval’ already exists
Known pipe types:
(all display modules loaded.)
:display:glxdisplay(warning): Couldn’t open input method.
Segmentation fault (core dumped)

I’m new to programming on linux…any help appreciated.


did you compile panda3d your self? - in that case try out one of our dally builds ( at the bottom)

if you done that and still having problem put

 notify-level-glgsg spam 

in our config file ( )

That will give us lots of info and hopefully some clue on what exactly is going on.

Alright, after putting that in, a few of them are working now! However, when I try to run the Firefly demo, it says

Toon Shader: Video driver does not support multiple render targets

I have an Nvidia geforce FX 5200 card, that works with everything else…so I don’t know what the problem might be.

Then, in the terminal, it continues to repeat

:display:gsg:glgsg(spam): binding vertex buffer 1
:display:gsg:glgsg(spam): binding vertex buffer 2
:display:gsg:glgsg(spam): draw_triangles: GeomTriangles, 114, 342
:display:gsg:glgsg(spam): glMatrixMode(GL_PROJECTION): [ 1 0 0 0 ] [ 0 1 0 0 ] [ 0 0 -0.001 0 ] [ 0 0 0 1 ]
:display:gsg:glgsg(spam): glEnable(GL_NORMALIZE)
:display:gsg:glgsg(spam): glDisable(GL_RESCALE_NORMAL)
:display:gsg:glgsg(spam): glClear(GL_COLOR_BUFFER_BIT|GL_DEPTH_BUFFER_BIT|)
:display:gsg:glgsg(spam): glMatrixMode(GL_PROJECTION): [ 2.79904 0 0 0 ] [ 0 3.73205 0 0 ] [ 0 0 -1.002 -1 ] [ 0 0 -2.002 0 ]
:display:gsg:glgsg(spam): glMatrixMode(GL_PROJECTION): [ 1 0 0 0 ] [ 0 1 0 0 ] [ 0 0 -0.001 0 ] [ 0 0 0 1 ]
:display:gsg:glgsg(spam): glEnable(GL_NORMALIZE)
:display:gsg:glgsg(spam): glDisable(GL_RESCALE_NORMAL)
:display:gsg:glgsg(spam): glClear(GL_DEPTH_BUFFER_BIT|)
:display:gsg:glgsg(spam): begin_draw_primitives: 228 rows: [ vertex(3f) texcoord(2f) ], [ color(4b) ]


Exactly that, with no change in numbers or anything.

Thanks for the help.


The configuration setting you changed is what’s causing it to print a lot of information. That information isn’t a sign of trouble, it’s what you asked for by setting that flag.

As for why it started working - no idea. As for why it has trouble with multiple render targets under linux - again, no idea, but everyone has that problem.

alright, thank you for your help. At least the majority of the demos work. :slight_smile:

I hope to be coding some games soon!

I’m on ubuntu gutsy, same card (Nvidia geforce FX 5200 card), and Render-To-Texture works great for me. I’ve had that problem before, and I recall I fixed it by disabling Xgl.

Mine didn’t have that file, so I created it, restarted, and still nothing … :frowning: Also on the Media Player example, I get an OpenAL support is not enabled, cannot proceed. Are the two related?

Hmm, maybe its a driver problem then.

Have you tried installing the tool envy to update the latest nvidia drivers, or have you used Gutsy’s system? I ask this since both systems use different drivers.

The OpenAL problem is not related. I recently added support for OpenAL audio, but I then discovered that OpenAL under Linux is buggy as hell. It was so crashy that I just had to disable it entirely. Unfortunately, the media player requires OpenAL.

I would be trying harder to make it work, except for one thing: I’ve noticed that there’s a team of programmers working really hard to get OpenAL in shape. They’ve been making leaps and bounds recently. I figure if we just give it a few months, they might very well get the problems sorted out.

I’m actually using Gutsy…so I’d assume my drivers are up to par. I really wish I could get this working.