Chicken problem

Sorry if this has been asked before, but search hates me. I am learning Panda3d from MGF magazine(thanks, Gary), so I wanted to build a simulated Solar system. Make planet(oid)s circle around the Sun or other Planet(oid), rotate them, maybe add Kepler’s Law of motion… Decided on that because of very simple models: spheres.
I “modeled” Earth and exported it using Chicken. In pview it shows just gray screen, but it creates egg. I load egg in simple “show model” program, but still can’t see it. I export it as .x and add it to program, still not there. I use Blender 2.49b, python 2.6.2, Panda3d 1.70 and Windows 7. I can see and use MGF models without any problems. I think I made a mistake somewhere. It won’t even work with the default cube.

After exporting with chicken. My blender cmd shows following:
Python loaded…etc…etc…
Known pipe types:
(all display modules loaded.)
Loading /d/Panda3D-1.7.egg
:loader(error): Couldn’t load file /d/Panda3D-1.7.egg: does not exist.
Unable to load /d/Panda3D-1.7.egg
:framework(warning): Empty bounding volume for models

Thanks in advance

Hello, the problem is this:

You’re loading a file that doesn’t exist. Maybe you’re having some problems with the path you’ve typed. If you post here the files needed (for example link a zip file) we can look at this. However Panda3D-1.7 is a weird name for a sphere. :slight_smile:

That is blender’s log. I used blender’s default name for a sphere(sphere.001, I think :slight_smile:).

Here are blend, blend1, egg(just a default cube), x, and texture files.

And the python file? However, the egg file you’ve posted is called earth.egg, while the file that Panda is trying to load in the OP is Panda3D-1.7.egg.

from direct.showbase.ShowBase import ShowBase

class Solar(ShowBase):
	def __init__(self):
		ShowBase.__init__(self) = self.loader.loadModel("earth.x")

app = Solar()

On my computer it works. Please note you haven’t disabled the mouse camera, so you’ve to press mousebuttons and drag a little in order to view the sphere.

Thx yaio. So stupid. Forgot that panda adds camera inside the sphere. Sorry for lost time. Lock please.

Are you kidding? :slight_smile: You’re welcome.