Cards rendering as black

Whenever I create a texture card using egg-texture-cards and then reparent it to render to put it in the 3D scene, it renders as black. I thought this was a lighting issue originally, so I tried turning up the node’s color but that didn’t fix it.

I tired setting the texture format to rgba within egg-texture-cards, using the -f flag. I also tried setting the filters to linear using the minf and magf tags.

I can get around the problem by making the cards in a modeling program myself, but I can’t help thinking I’m missing something.

It might still be a lighting issue. Turning up the color won’t have any effect if your lights are making an object black. Have you tried explicitly disabling lighting with card.setLightOff()?

Though it is odd that your own cards render fine, while cards created with egg-texture-cards render as black. Can you view the card in pview?

David

setLightOff() worked, thanks.