Can't Run

i can’t seem to run this program i am working on windows vista i try running panda3D and panda3Dw please help

also i really wasn’t sure where to post this if in wrong section sorry

You’ll need to provide more information about what exactly you did and what isn’t working for you, and post any error messages you got here.

well basically when i ran panda3Dw nothing happened and when i ran panda3D a black box came up and faster than i could read the text it disappeared there were no error messages at all

You should know that Panda is not a program that you can run. It’s a set of libraries that you use to build your own programs. There’s no program called panda3Dw, and no program called panda3D, but maybe you’re thinking of pythonw and python?

Panda3D does come with samples, which are simple little programs written with Panda, which you can run directly. You can run them by selecting them from the start menu, but it also helps to run them from the command line, so you can see their output (otherwise the window may come up and go away before you can see anything).

See the introduction chapters in the Manual.


I think he installed the Runtime, which does ship with panda3d and panda3dw. These tools exist to run already existing .p3d games.

Ah, yes, of course! We’ll have to be attentive to questions like this in the future–the “how do I run this program?” confusion is still there, but now there are two different contexts in which someone might have “installed Panda”.


Hey you have not mention that which error message you are getting. If you have any code or file or screen-shot for it than you can share it here so that we can get the proper idea about it that where actually you are facing the problem.