can't get packp3d to work

packp3d app.p3d -d folder
The Panda3D Runtime does not appear to be installed!

Runtime is installed (1.04), Panda is installed (1.8.1). Windows 7.

Try invoking the runtime explicitly, ie.

panda3d.exe path/to/ -o app.p3d -d folder
panda3d.exe c:\Program Files (x86)\Panda3D-1.8.1\bin\packp3d.p3d -o
app.p3d -d c:\Users\User\Desktop\folder
:downloader: [00A9C720] begin GET [
3157294 ]
:downloader: [00AAECE0] begin GET [
_plugin.dll ]
No such file: /c/Program

Apparently doesn’t support parsing whitespaces? :unamused:

Anyway, I reinstalled Panda in its default location which doesn’t have whitespaces and it didn’t give that error.

Is this a bug that is being worked on, kind of annoying. :frowning:


:AppRunner: Total Panda3D disk space used: 150 MB
:AppRunner: Configured max usage is: 2048 MB
No Python files in root directory.

“” in c:\Users\User\Desktop\folder

You have to either quote the path or escape the space, otherwise it will be recognised as two separate arguments. It’s not a bug in Panda; it’s how every command-line program works.

Try running it from the directory where the Python files are located.


have you tried to specify the main python file with the -m argument in your case I think it could be
anyway I find your error weird that you are having because it is supposed to default to as -m