Cannot run


I recently just downloaded the most recent version of Panda3D for the first time. Well, when I go to run scene editor in command prompt, I get this error:

ImportError: No module named MouseWatcher

I am sorry to help NOT directly… but you are higly encouraged to use the “search” button… if you type there “MouseWatcher” you will get round about 5 topics related to exactly that problem.

Thanks in advance.

Now the less-snobbish-version: The problem is known. Search the forum and you will find how to get around that. If you want a mostly-working Scene Editor, get Panda 1.0.5 and wait till they get the error cleaned version (and thus not any longer a beta) of 1.1.

Regards, Bigfoot29

Maybe this thread can help you


Please also note that (for all I know) you cannot run the scene editor by just typing “ppython”. It has to be invoked through an import statement (which I have to admit I don’t remember) - better check the first video tutorial linked in the manual.

You can perfectly run the sceneEditor via ppython command line.

Really? When I tried it some weeks ago (1.0.5, Windows version) it failed for whichever reason… In contrast, the initialisation shown in the video tutorial worked fine.

I use scene Editor every day (before migrating to Panda 1.1 ) and i never imported it…

However it was not running from scratch, a few path and import had to be updated …

Ok, maybe that was my mistake - assuming everthing ready and done. I’m still new to P3D, after all. :slight_smile:

Anyway, I think it’s good sharing the mistakes you have made yourself, it’s quite likely that you’re not alone. :slight_smile: