Cannot resize the window with pandadx9

Hello everyone!
I have the following problem.
I create multiple windows in panda3D with pandadx9 instead of pandagl, but when I try to resize one of the windows, the program crashes with this message:

Process finished with exit code -1073741819 (0xC0000005)

The problem doesn’t appear related to the graphics card, I tried it on 2 computers, have the same issue. But for the reference, card that I am using is NVIDIA GeForce MX330

The problem is DirectX issue, when I use OpenGL, everything is fine (however I would like my code to work with DirectX as well)

The issue appears only with multiple windows: when I create only one window, resizing works perfectly.

How I create these additional windows: I’ve tried 2 options:

base.graphicsEngine.makeOutput(base.pipe, 'window', 10, core.FrameBufferProperties.getDefault(), core.WindowProperties.getDefault(), core.GraphicsPipe.BFRequireWindow)

Although I am not sure if there is a difference between these 2 ways.

When I try to make the windows fullscreen from the start (by changing in Config.prc to fullscreen #t), it crashes with the following error:

:display:wdxdisplay9(fatal): D3D CreateDevice failed for adapter #0,  at (c:\buildslave\sdk-windows-amd64\build\panda\src\dxgsg9\wdxGraphicsWindow9.cxx:686), hr=D3DERR_INVALIDCALL: Invalid call
:display:wdxdisplay9(error): Unable to create window with specified parameters.
:display:wdxdisplay9(warning): ID3D9 released but still has a non-zero refcnt(1), multi-releasing it down to zero!

However when I make full screen with only one window, it works great.

Could you please help me to pin down where the problem might be?

I checked this, and indeed the app crashes quietly.

Could you please file a bug report on GitHub? Thank you!