bullet soft bodies visualization issue

In reviewing the operation of the bullet soft bodies, I experienced an issue with the visualization of any soft body (except the rope): the GeomNode(s) attached do not deform following the modification of the soft bodies but remain rigid.
To observe the problem just run any of the bullet samples related to soft bodies.

I tried to find out what is causing the problem, unfortunately I did not succeed; however, I discovered that if the soft body is removed from the camera view, the GeomNode undergoes a deformation that is again visible when subjected again to the camera. This makes me think that the problem might be due to the culling and/or clipping and/or bounding volume etc…??
Here is a video that shows what I have described by executing ‘python 22_SoftbodyCloth.py’ (from bullet samples):


The system on which I have taken the test is
-panda3d latest commit
-bullet 2.83.7
-ubuntu 16.04
A help is very welcome

I have the same problem in Panda3D-1.10.0-x64
However: in version Panda3D-1.9.2-x64 is running.

Following a drastic “revert commit-build-test” cycle, I found that this issue is due to the last changes made on these files:


So going back to the previous version (commit 0fcfb8e on 17.02.2016) with the command:

git checkout 0fcfb8e panda/src/putil/copyOnWriteObject.h panda/src/putil/copyOnWriteObject.I panda/src/putil/copyOnWritePointer.cxx

would solve the problem.
PS: obviously, reverting to the previous version undoes changes designed to solve a given problem (“fixing of race cond in async flatten”), so an in-depth analysis of the problem (by core developers) is needed.


I’m having the same problem in Arch Linux, I tried installing Panda3d from AUR with three different versions of bullet avalaible on repos:
Bullet 2.85 from Extra Repo
Using Bullet Version 2.83 from git
With Bullet3 from Git

The same process was repeated using Panda 1.9.1 With the same results. So I will try the solution given by Consultit.

Umbriel, your problem must be different, since consultit’s problem does not exist in 1.9.2. Please create a separate thread or bug report about your issue.

consultit, I couldn’t reproduce the issue, but then I found out I still had some local performance tweaks to that file without which I could reproduce the issue. Odd. I checked in my changes, could you give it a try?

I just built with these changes, and all seems to come back to work.
Very good.