Build error (ffmpeg on windows again)

here is the build error (with verbose)
Already tried with and without thirdparty folder and both using the included ffmpeg an compiling ffmpeg svn last version with --prefix option:

[ 26%] Building C++ object built/tmp/movies_composite1.obj
cl /wd4996 /wd4275 /wd4267 /wd4101 /Fobuilt/tmp/movies_composite1.obj /nologo /c /Ipanda/src/movies /Ithirdparty/win-python/include /Ithirdparty/win-libs-vc9/ffmpeg/include /Ibuilt/tmp /Ibuilt/include /MD /Zi /O2 /Ob2 /DFORCE_INLINING /Fdbuilt/tmp/movies_comp
osite1.pdb /DBUILDING_PANDA /EHsc /Zm300 /DWIN32_VC /DWIN32 /W3 panda/src/movies/movies_composite1.cxx
c:\panda3d\panda3d\panda\src\movies\ffmpegVideoCursor.cxx(23) : fatal error C1083: can’t open include file: ‘libswscale/swscale.h’: No such file or directory
Storing dependency cache.
Elapsed Time: 20 min 43 sec

Build terminated.

Is this the latest CVS? Update it to today’s. I’ve checked in some changes the day before yesterday that should get rid of this issue.

if last CVS doesn’t work and you can live without ffmpeg simply disable it when running the makepanda script…

I can’t live without ffmpeg… sniff.

With latest CVS you can just specify --no-swscale (to be certain) and you’ll be sure that it doesn’t try to pick it up.

here is a new error:
python makepanda\ --everything --installer --verbose --no-swscale

[ 92%] Generating ‘pandac’ tree
thirdparty/win-python/python.exe direct\src\ffi\ -r libpandaexpress libpanda libpandaphysics libpandafx libp3direct libp3vision libpandaskel libpandaegg libpandaode
Traceback (most recent call last):
File “direct\src\ffi\”, line 74, in
from direct.ffi import DoGenPyCode
File “C:\panda3d\panda3d\built\direct\ffi\”, line 11, in
from direct.ffi import FFIConstants
File “C:\panda3d\panda3d\built\direct\ffi\”, line 3, in
from direct.directnotify.DirectNotifyGlobal import *
File “C:\panda3d\panda3d\built\direct\directnotify\”, line 3, in
import DirectNotify
File “C:\panda3d\panda3d\built\direct\directnotify\”, line 5, in
import Notifier
File “C:\panda3d\panda3d\built\direct\directnotify\”, line 6, in
from direct.showbase import PythonUtil
File “C:\panda3d\panda3d\built\direct\showbase\”, line 54, in
import ElementTree as ET
File “C:\panda3d\panda3d\built\direct\showbase\”, line 2182


SyntaxError: invalid syntax
Storing dependency cache.
Elapsed Time: 2 min 53 sec

Build terminated.


I think you might have aborted the makepanda build while it was copying the “direct” tree, you can just delete “built/direct” to force makepanda to copy it again on the next build.

I had the same error too. I think there is a problem with the line breaks in direct\showbase\ (on Windows). I replaced all line breaks with standard DOS line breaks, and was able to compile.

Same problem.
Already deleted the build folder an made a clean cvs checkout.

Ah, you’re right–there was indeed a problem with the line breaks in this file. Fix committed to CVS.