Bug in EggTexture ?


When adding support for several different texture types in my collada exporter, I saw the EggTexture.set_texture_type function and thus made my exporter fill in this value based on what the Collada file specifies as texture type. But, when I write it to an .egg file, it doesn’t recognize this texture_type parameter:

:egg2pg: Reading blah.egg

Warning in blah.egg at line 8, column 30:
  <Scalar> texture_type { 2d }
Unsupported texture scalar: texture_type

According to the eggSyntax.txt, it should be texture-type. I tried changing that in eggTexture.cxx. But, this doesn’t work as well, with the same error (it doesn’t recognize texture-type this time).

Any help would be greatly appreciated.

Sorry, I didn’t look right. It should have been “type”. I checked in a fix for this bug to cvs.

While we’re talking about bugs in eggTexture.cxx, I found another one. I described it here:
The programmer probably forgot to change the values after copying&pasting, or was this intentional?

Ah, thank you. Yes, you’re right, that was just a paste-buffer error. I just checked in the fix.