Browser plugin nearing completion

I just accidentally introduced, and then fixed, some bugs in Firefox. Download the plugin again and try it again.

I don’t know what the coreapi problems are. Are they still occurring after you download the latest plugin?

The MS Path is an interesting bug. I know what’s going on–it’s looking for MSVS on your system, in case you want to use it to generate a compiled DLL. I guess it’s probably not installed on your system (and no reason it should be). It shouldn’t really do this until you actually say you want to generate a compiled DLL, so I can fix that–I just never noticed this bug because I have MSVS installed, so I never saw that message. :slight_smile:

BTW, Linux (i386) users can download this program: http://www.ddrose.com/~drose/p3d_7/plugin/linux_i386/panda3d and Mac users this one: http://www.ddrose.com/~drose/p3d_7/plugin/osx_fat/panda3d to use in conjunction with the above packp3d.p3d link. Make the programs executable, of course. Note that both of these are temporary programs that should be replaced with the actual panda3d programs when we get the official plugin released.

David

Actually I have MSVC2005 installed, but I don’t think I have any paths to it yet, so that would make sense.

Downloading the plugin now! (Thanks so much for the quick response ^^)

I redownloaded the plugin from ddrose.com/~drose/plugin/install_plugin.html but it still says I have version 0.9.1c after installation and firefox restart. Is there another url?

Also, is there a way to turn off the dll search, or should I just throw another folder into my Environment path? :slight_smile:

LoadPlugin: failed to initialize shared library /home/nemesis13/.mozilla/plugins/nppanda3d.so [libpython2.4.so.1.0: cannot open shared object file: No such file or directory]

OS: GNU/Linux
Arch: i686 / 32 bit
FX: Gecko/20090913 Shiretoko/3.5.3
Panda: custom CVS build from 10.10.2009
Python: 2.6.3

Empty your browser cache and try again.

Try setting the two environment variables VCINSTALLDIR and WindowsSdkDir to something nonempty, like ‘x’.

Oops, I’ll get that straightened out soon.

David

I managed to make one of the samples into a p3d and run it. It seems to work. I’m on mac os x 10.5 btw.

I had as issue with the sample I chose (Asteroids) no being able to load it’s font, so I took the font stuff out and it worked. I figure there is some font file that would just have to be moved into the directory.

The other project I tried to p3d got a syntax error on one of my class definitions:

I actually got 2 almost identical copies of this error. (Ones traceback started deeper)

This may be the fault of a difference in python versions (did you say you use 2.4 or something for the p3d stuff?). I guess its possible I did something that posses off the python you used, but not my regular python. I’ll try some other and simpler projects soon.

Also, it seemed I needed to use a full path to panda3d to make it run (even from its directory), but thats probably because I suck at all this command line stuff.

Thanks! It works! :slight_smile:

Edit: On the flash demo, the shapes make it from panda to flash, but they disappear instead of making it back to panda. This might the the intention, but it could be a bug too, so I though I would point it out.

Exactly. You’d have to copy cmss12.egg/rgb into the Asteroids folder, or change the Asteroids code to use TextNode.getDefaultFont() instead of cmss12. (I’m not entirely sure why it goes out of its way to use that particular font, since it looks so similar to the compiled-in default font anyway.)

Right, in Python 2.4, the empty parens weren’t valid. You have to do this instead:

class Bakery:

which is valid in all versions of Python. You may encounter other minor Python version issues. The real release of the plugin system will use Python 2.6, the same version that Panda3D 1.7.0 will be built against.

Try something like ./panda3d when you are in the panda3d directory.

David

The firefox issue is fixed from what i can tell, thanks for the quick reply :slight_smile:

But while i’m not getting the same errors, i’m still getting errors:
(downloaded carousel.p3d from your demo)

C:\Users\Logan>panda3d carousel.p3d
:downloader: Lost connection to www.ddrose.com:80 (-1).
:express(warning): error:0D06B078:asn1 encoding routines:ASN1_get_object:header
too long
:express(warning): error:0D09F006:asn1 encoding routines:d2i_X509:bad get asn1 o
bject call
:downloader(warning): Windows error code: 10054

Something strange is that when i got that error, it showed the panda logo with a red “oh noes” symbol. running it again i don’t get the error and the window stays blank. Same thing happens with packp3d.p3d.

And yet it works fine on the web page? Strange. Do you have a proxy setting or anything like that in your web browsers?

David

Thanks David, that fixed it. Now I have some other issues. My app reads in text files with pythons I/O stuff which I don’t think gets along with the multifile too well.

Is there a way to get a reference to the multifile everything is in, or some way to open text files that will work for both p3d builds and just regularly running from my source directory?

Also, when I initially ran panda3d to try and package something (which caused it to perform the install) I got a pretty big pile of warnings and not found function pointers. Would you like a copy of the output?

Well I got a P3D file! Here’s the next set of errors >.>; The window does start, but it’s black.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Raz>cd C:\

C:\>cd Panda3D-1.6.2

C:\Panda3D-1.6.2>panda3d packp3d.p3d -o razTest.p3d -d C:/Panda3D-1.6.2/samples/
Chessboard
Freshening https://apollo.ddrose.com/~drose/p3d_7/panda3d/dev_7/win32/panda3d.de
v_7.win32.import.xml
There are some missing modules: ['TkGlobal', 'WxGlobal', 'libheapq', 'libp3direc
t', 'libp3heapq']
:loader: loading file type module: pandaegg
:egg2pg: Reading /c/Panda3D-1.6.2/samples/Chessboard/models/bishop.egg.pz
:egg2pg: Flattened 1 nodes.
:egg2pg: Reading /c/Panda3D-1.6.2/samples/Chessboard/models/king.egg.pz
:egg2pg: Flattened 1 nodes.
:egg2pg: Reading /c/Panda3D-1.6.2/samples/Chessboard/models/knight.egg.pz
:egg2pg: Flattened 1 nodes.
:egg2pg: Reading /c/Panda3D-1.6.2/samples/Chessboard/models/pawn.egg.pz
:egg2pg: Flattened 1 nodes.
:egg2pg: Reading /c/Panda3D-1.6.2/samples/Chessboard/models/queen.egg.pz
:egg2pg: Flattened 1 nodes.
:egg2pg: Reading /c/Panda3D-1.6.2/samples/Chessboard/models/rook.egg.pz
:egg2pg: Flattened 1 nodes.
:egg2pg: Reading /c/Panda3D-1.6.2/samples/Chessboard/models/square.egg.pz
:egg2pg: Flattened 1 nodes.
Generating razTest.p3d

C:\Panda3D-1.6.2>

Oops, no, this is my bad: I failed to add ‘sha’ to the list of extensions that should be added to the multifile. So your shader really is missing. Try renaming it to mapMaker.cg instead (and changing the code accordingly).

For the record, we automatically substitute the open() call in direct.stdpy.file, which is capable of opening files directly from a multifile.

David

Just did a full browser cache clear, still says I have 0.9.1c, I wonder if I’m completely missing something obvious >.>;

I don’t see any actual errors there. Looks like it built a p3d file normally. When you say “the window does start, but it’s black,” are you referring to the window that you see when you attempt to run the p3d file just produced?

Are these similar to the missing modules report listed in Raz’s output? It’s normal for a bunch of modules to appear to be missing. This is part of the nature of the Python language, where it’s impossible to tell from the code alone whether an import references a global file or a file in the local directory; and also due to Python’s modulefinder, which checks every import even those that are never executed due to conditionals.

David

Hmm. Maybe it’s not getting reinstalled properly? Try uninstalling the Panda3D plugin via the add/remove programs dialog in the Control Panel, then confirm that the browser shows it’s no longer installed. Then download and install it again.

David

Cool. Well, I tried .cg, .txt, .pz (not actually p zipped though) and no extension all with the same result.

I believe this is the same error I get if I launch my app from the wrong directory, though probably a different cause.

Edit: I tried to list the contents of my p3d, but multify could not open it. I guess I probably need a newer multify. I tried my semi out of data 1.7.0 one and my 1.6.2 one, same result.

Well, you can look at it:
dpaste.com/109552/

Yeah, when I doubleclick on the P3D file, I get a black window and then it closes.

Also, I tried uninstalling the Panda game engine, and the page still said I had 0.9.1c, reinstalled, after I ran one of the demo’s again, I did get updaed to rev_7, but still having trouble generating a working P3D from the demo.

Woo, aren’t we burning the midnight oil xD

Ah, bingo. Right, the current directory isn’t going to be the app directory at startup. (Hmm, I wonder if it should be? But probably not–the app directory isn’t writable.) In order to load the file successfully, you will have to find it first. There are several approaches. The root directory will be in base.appRunner.multifileRoot; you could simply concatenate this with your filename.

Hmm. Not a terrific solution in general, though. Is there any particular reason you’re reading the shader file directly instead of using loader.loadShader()?

Ah, these error messages indicate you’re not running the most current version of the Panda3D runtime that I uploaded this afternoon. Hmm, try running panda3d with the -f parameter; or visit my demo page with a browser and view any of the demos. Either of these should force the latest Panda3D runtime to be downloaded.

OK, sounds like something’s wrong with the file associations. Try running the p3d file from the command line with panda3d.exe, the same way you run packp3d.p3d, and let me know how that works.

So uninstalling didn’t work. Did you close all of your browsers before you uninstalled? If not, close them all now, and try it again–I’d like to know if it’s possible to uninstall you properly. Which browser are you running?

I’m in California. It’s not midnight for me yet, but it’s getting closer. :slight_smile:

David

I already am passing around path variables, so appending that should not be much of an issue. I’ll try that soon.

In this case, I’m generating the shader from several files. Its my own little shader generator specifically for tendering textures for generating terrain. I have that shader file, which is littered with placeholders that get replaced by code and parameters from my other files.

This only happened once (the first time I ran it), and was immanently followed by a successful download. I though they may have been errors from the install process, but I guess they weren’t. Spamming lots of apparent errors during a successful update is a bit misleading.