bout panda 1.3.2 in ubuntu 6.06 dapper drake

I have instaled panda 1.3.2 ppython are running ok and the path is ok too.
but when i try run the following message is showed.

DirectStart: Starting the game.
Warning: DirectNotify: category 'Interval' already exists
Known pipe types:
(all display modules loaded.)
:display(error): The application requested harware acceleration, but your OpenGL:display(error): driver, Mesa GLX Indirect, only supports software rendering.
:display(error): You need to install a hardware-accelerated OpenGL driver, or,
:display(error): if you actually *want* to use a software renderer, then
:display(error): change the word 'hardware' to 'software' in the Config.prc file.
:display(error): Window wouldn't open; abandoning window.
:02-11-2007 10:35:42 ShowBase(warning): Unable to open 'onscreen' window.
Traceback (most recent call last):
  File "/usr/share/panda3d/samples/GreetingCard/", line 1, in ?
    import direct.directbase.DirectStart
  File "debtmp/usr/share/panda3d/direct/src/directbase/", line 4, in ?
  File "debtmp/usr/share/panda3d/direct/src/showbase/", line 195, in __init__
  File "debtmp/usr/share/panda3d/direct/src/showbase/", line 572, in openDefaultWindow
StandardError: Could not open window.

I have in my pc a NVIDIA GeForce 4 MX 4000 128Megabytes video device AGP that was correctly configured, Is it a hardware acelerator?? Is there a driver for this device that I can use to fix these prolems?? Have i choose the software rendering option?? how could i choose this option? please someone help me

i changed in Config.prc the system redering for software rendering but the software rendering is a bad performance.
what can i do

Your card may be “correctly configured” for standard 2-d acceleration, but it doesn’t appear to be configured for 3-d acceleration. You will need to install a driver from nvidia that enables your graphics card for 3-d mode. Try going to and following the instructions there.


I believe with Ubuntu 6.06 you can actually install the nvidia drivers through a built in package (probably in the universe repository). Search for “nvidia-glx” using Synaptic or whatever software installer you use.

i’m running Ubuntu too.
I had that problem first, too (i use nVidia card too.). I installed in synaptic a few opengl and nvidia packages and it was solved.
Note: panda3d doesn’t work too in Ubuntu if you have Beryl and have the Blur filter enabled.

thank you very much for your support