I would like to introduce BlenderPanda, a Blender addon for Panda3D integration. Some of the features of this addon are:

  • Rendered Viewport (preview how Blender scenes will look in Panda)
  • Project quick-start (setup common directories and files for your new project)
  • Launch your game from inside Blender (launches as a separate application)
  • Automatically convert blend files to BAM files when running your game
  • Can be used with existing projects

Documentation for getting started with BlenderPanda can be found here.

Some known limitations:

  • No physics support
  • No PBR materials
  • Does not make use of Blender’s logic bricks (not sure how much of a limitation this is, but worth noting)
  • Blender objects that are not supported by glTF (e.g., text objects, speakers, particle systems, etc.) are not converted

BlenderPanda is still very much a work in progress, but it is time to start collecting some feedback to help prioritize development. So please, give BlenderPanda a try and let us know what you think!

1 Like

I walked along this path but declined.

I will give priority to the export of eggs all opportunities.
Studio is better to write on the engine panda. My humble opinion.

While BlenderPanda can do BAM exporting, the goal of the project is to improve workflow, not to create yet another Blender to Panda exporter. In the future, the plan is to allow more export options (although this is very low priority at the moment), and to eventually replace BlenderPanda’s current BAM export process with this BAM exporter to avoid duplicate efforts.

Even if you’re using EGG exporting at the moment, the rendered viewport can still be used to preview a scene using Panda in Blender’s viewport. Also, if/when more export pipelines are support, it should be possible to take advantage of build/auto-build functionality of BlenderPanda while still using EGG.

It is not clear how to install the add- in bleder
I run git command 's console

What’s next ?
Accommodation in addons folder does not result…

I got it, found in the masonry testing

However, all is not without errors)
ImportError: No module named machinery

Which part is failing?

  • Can you see the addon in Blender’s User Preferences?
  • Can you enable the addon?
  • Can you enable the rendered viewport?
  • Since I see you’re on Windows, is ppython on your PATH and can you run a Panda3D application?

On another note, animation support is now much improved. There are still some quirks to be worked out, but more complicated characters no longer degenerate into a writhing mass of verts at the origin.

My actions:

The installation path , a string of environment variables:

C:\MinGW\bin;C:\CMake\bin;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\AMD APP\bin\x86_64;C:\Program Files (x86)\AMD APP\bin\x86;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL Server\100\DTS\Binn\;D:\Panda3D-1.9.1-x64\python;D:\Panda3D-1.9.1-x64\python\Scripts;D:\Panda3D-1.9.1-x64\bin;C:\Program Files\Microsoft Windows Performance Toolkit\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Panda3D-1.10.0-x64\python;C:\Panda3D-1.10.0-x64\python\Scripts;C:\Panda3D-1.10.0-x64\bin

Thanks for the video; I’ll look into reproducing the issue.

Looks like importlib.machinery was added in Python 3.3. I’ve pushed a fix to support versions of Python that do not have importlib.machinery.

Traceback (most recent call last):
  File "C:\demo\game/", line 6, in <module>
    import blenderpanda
  File "C:\demo\game\blenderpanda\", line 1, in <module>
    from .bpbase import init
  File "C:\demo\game\blenderpanda\", line 1, in <module>
    from .rendermanager import create_render_manager
  File "C:\demo\game\blenderpanda\", line 11, in <module>
    from . import pman
  File "C:\demo\game\blenderpanda\", line 1, in <module>
    import configparser
ImportError: No module named configparser

After fix.

This was another Python2 issue. I installed a Python2 version of Panda (which I should have done earlier), and worked through some issues. BlenderPanda should now work a lot better with Python2.

However, there is some progress, but…

The first issue I think is due to your not doing anything interesting. The generated does not load any models, move the camera, etc.

For the second issue, it looks like there is an issue with the spawned Python process that runs Panda3D. Is there a different error message before those WinError 6 messages?

Not looked

The plugin does not create Content in the folders. How to export?
Or this plugin to create folders :slight_smile:

The addon will export all blend files in the asset directory (./assets by default) to the export directory (./game/assets). The generated puts ./game/assets on the model path, but it is up to you to figure out which models you want to load. The Run Game button launches your game. If your game does nothing, then don’t expect there to be anything in the window. If you want to preview the scene as it is shown in the Blender viewport, there is the rendered viewport.

I wanted to say, the assets folder is empty.

Then there must have been an error in the conversion step. Do you see an error in the console when using either the Build Game or Run Game options?

Here new no.

Okay, I see what’s happening now. You have no blend files saved in your asset folder. If you save the current blend file into the top level assets directory, is should start converting that file.