Black Particles? <-- maybe a pandadx9 renderer vista bug!

EDIT
This only occurs if the pandadx9 renderer is used on vista. Using the pandagl renderer works flawlessly.
Note - The only reason I switched was because NVidia’s drivers wouldnt work with the opengl renderer (nvidia’s fault). On an ati based x86 vista pc the opengl renderer worked where the pandadx9 renderer had the black particles problem.
EDIT

Hi

All the particles I load up from .ptf files (which load up sprites) are appearing black! This is irrespective of the colour of the sprite.

I think it has to do with me not setting the lighting from my lights active on the particles - but how do i accomplish this? If it isnt a lighting problem - what could it be then?

If anything, I suspect it’s probably that you do have lighting enabled on the particles. You generally don’t want to have lighting on sprite particles, because their normals aren’t generally meaningful. Try turning lighting off.

David