Beryl and black Panda3D windows...

My first post here, and a technical topic already… :wink:

I compiled Panda3d from source for my Mandriva 2007 “One” installation here… no big issue with “makepanda”.

Runs fine as far i can see it at the moment, but there is one little issue left.

If “Beryl” (…yes, our beloved 3D-Desktop-Manager) is active, Panda3d seems to have little problems while starting up, at least for all the stuff in the “samples” directory.

For example: "GreetingCard ":
Music starts playing (so the script itself is running) but the window remains black… but after clicking in the window it runs fine and shows the walking/dancing panda in all its glory.

The “bug” is gone if i switch Beryl’s render path to “Copy”, but it gets very slow… so no acceptable solution.

With no beryl active, the “bug” is gone…

Well, i know that beryl is somewhat “beta” (well, more “alpha”…) and
there are some still issues with the graphic card drivers (even with the
otherwise good nvidia ones, the “black window bug” for example… which
looks quite similar but seems to something different, because no mouse click helps in that case), but i would like to know if someone knows something about this issue?

Thanks in advance,


I have seen the same with both Compiz and Beryl on FC6 using Panda from the FC6 rpm from this site. I did not look for a solution yet. Something happens when you click with the mouse that fixes it, so if we can figure out what this is …

You’re running two 3D programs (panda and beryl) on only one graphics card.
Maybe panda just needs the click to know that it’s time for it to take control of the card.
Have you tried other 3D applications (some games, such as tux racer) with beryl running?


I’m running beryl too. I have the black-window-problem too, and it just fixes if I switch off the Blur filter.

Yes, i tried at least Super Tux Racer, which runs fine.

So it does’t seem to be OpenGL specific… i think?

That’s an odd but not all so annoying bug anyway…

I mean clicking into the panda window shouldn’t be too annoying, and pro-soft found a little workaraound.

It is indeed interesting, but I think we would need someone with a more detailed understanding of how beryl works to help us understand that problem.
Maybe it’s a coincidence, where beryl and panda are trying to use the same resources of the graphics card… But I’m just guessing.

I don’t think that it’s that annoying, too… But at least it’s interesting and could confuse some users (…and i mean users of programs which use software using panda3d, not us, the programmers…)

So, if i got that right, it’s sufficient to switch of the blur filter… would be interesting if there are other work arounds, to force the focus (or whatever is needed) on the panda3d window…

Well, i’m just beginning with panda3d, maybe i will have an eye on this issue during my learning process…

Hi all,

I have the same problem on Ubuntu 6.06 on an HP nx6110 laptop, which
has an Intel i915GM graphic card. After I run some sample, the screen becomes gray or black. If I do something on the screen (resize), it starts to show the execution (graphics, texts, whatever).
I suppose it is a problem of GNOME, Xorg and i915 video driver but I am not sure.
On the other hand, I have tested pre-compiled panda 1.3.2 and myself compilation, in both cases, the problem seems to be the same.

You can just click inside the window, that will work too :wink: