bam and hidden meshes

i am writing out a .bam file with


the nodePath does include hidden meshes. it seems that the hidden meshes are also saved into the bam file (which is ok and understandable).

if i view the .bam file in pview i will see the mesh as i want - without the hidden meshes.

when i convert the .bam file to a maya .mb file (bam2egg and then egg2maya) the resulting maya file includes the hidden meshes but they are visible in maya.

so it seems that pview does take the hidden flag into account when displaying the mesh, but egg2maya will loose this information and not forward it to the .mb file.

can this easily be fixed?

until then, is there an easy way to create a copy of a NodePath and removing the hidden objects, so i can save out the NodePath as a .bam file and ignore the hidden objects. that’s at least what i want - i do not need the hidden objects in the bam file really.

hm, thinking about this, is the NodePath.stash command maybe of help?

stash all objects i do not need, save the NodePath, unstash all. will this result in a bam without hidden meshes (and thus they won’t also be in the maya .mb file)?


yes, this worked fine. when stashing an object it won’t be written out in the bam file and won’t be found in the final maya .mb file. so i have a solution.

(though it would still be nice if the hidden flag was forwarded to the maya file correctly :wink:)