Animations : the armature for doing only eyes blinking changed to the whole face

when i load my model with eyes blinking that made by an armature in blender on panda i see a different animation that the head move (the armature animate on panda the face and not the eyes but in blender works fine and does blinking)

i used this command to convert .blend to bam with animation and the actor :
blend2bam -m pbr --pipeline gltf --animations separate “shamatestAnim.blend” “face.bam”

I think the best solution here is if I just make a facial animation demo so that people can study it. No promises when that will be released. :slight_smile:

i need it urgently tha is why i am here now. if you have an idea about that problem or if you didn’t understand the problem i can explain more :

i had one armature that do in blender action only eyes movements (blinking) but when i used this command an get the animation and the mesh i load it in panda but the animation that i get it is only head movement which i didnt do this animation for the head the armature change the animation for eyes blinking and apply it for the whole head

What’s probably happening is that the converter is blending all the head vertices onto your eyelid bones.

You may want to do custom paint weighting when you bind your mesh to the head armature, in Blender. You can find a large number of YouTube tutorials on this topic.

Really, only experimenting with your particular model and armature can help you at this point.

what i just did i set weightes only for this parts in blender an it works fine in blender


Based on this, do I understand correctly that you have multiple armatures? Not just one that has multiple animations, nor even multiple separate bones in a single armature, but multiple separate armature-objects?

If so, then I wonder whether that’s not the problem. What happens if you do the following?

(Note! To be safe, I recommend backing up your current files before doing these things!)

  • Delete all of the model’s exported files, including animations
    • This so that old data doesn’t interfere with new
  • In Blender, remove the eye armature completely
  • Similarly, delete the “action” that holds the eye animation
  • Next, edit the main armature and add to it the relevant bones for the eye animation
  • That done, create the animation again
  • Finally, export your model once more and see how it loads

this is what i just did again i use just one armature for the eyes blinking but when i load it to panda the armature move the head not the eyes :

this is the blend file.

and the command i’m using to seprate the animation is : blend2bam -m pbr --pipeline gltf --animations separate “shama.blend” “face.bam”

i do not know what is the problem with these

You say that you use just one armature for the eyes blinking, but do you have another armature for the head?.

Let me ask it this way: How many armatures does your blend-file have in total? Regardless of whether they control the eyes or the head.

(Again, I doubt that I’m in a position to open the blend-file that you posted, as I’m still using an older version of Blender. Sorry about that!)

i am using only one armature for eyes blinking i do not have another one for the head you get me ? you can open it maybeeven if older version

Okay, that is clear–and thank you for clarifying; it’s appreciated!

Okay, so, does the head have an armature modifier, and if so, does it reference the eye armature?

I’ve tried a few times before with such files, and it has never worked.

no the head has no armature modifier. the only armature i have is the one for eyes blinking

Hmm… Then I don’t know!

I gather that the new tools (such as blend2bam) have some complications that the old tools don’t have, and lacking familiarity with the former I fear that I’m not in a good position to help with them.

I suppose that one last desperation tactic, if you’re really pressed for time, might be this: Is it important to you that this model use the PBR pipeline or nodes? Is it feasible to import your model into an older version of Blender? If the answers to those are “no” and “yes”, respectively, and if time is running out, then perhaps you can use an older version of Blender (e.g. 2.78) along with YABEE to export your model.

yes i will do it now i will install the 2.78 and do the same again and see. hope you stay tuned

Good luck! I hope that you get it working!

do you think the problem can be in the command : blend2bam -m pbr --pipeline gltf --animations separate “shamatestAnim.blend” “face.bam”

No idea, I’m afraid. As I said, I don’t yet use the newer tools, myself.

i imported the anim as .egg and i get a blank window when i load it to panda
shama1.egg (375 Bytes)
shama1-blinking.egg (2.2 KB)

Yup, looking at those files, there doesn’t seem to be a model present within them.

I take it that these were exported via YABEE? If so, did you have all of the relevant models, as well as the armature, selected when you ran the exportation? YABEE only exports what you select, I believe.

yes you are alright about that but when i do it i part of the face has no color

I’m seeing some colour there, I think–it’s not pure whiteness.

However, it does also look somewhat washed-out, and appears to have some transparency issues. I would imagine that there are issues with your materials.

Note for one that I don’t think that YABEE exports node-based shaders or the like–if you have any of those, you might find that replacing them with old-fashioned materials is called for.

I might also guess that something is being erroneously interpreted as transparency, judging by the way that the neck and hair fades out at the ends. What that might be I’m not sure, I’m afraid.