Animation Not Working/In Geany

I tried to make a Toontown animation in Geany as a finished version of a tutorial.
After copypasting everything in, clicking execute, pview loads, but then stops and I am greeted with this error message (WARNING LONG):

:loader(error): couldn’t load file phase_3.5/models/char/suitB-mod.bam: not found on model path (currently: “/c/users/owner/desktop;/c/users/owner/desktop/panda3D-1.9.4/etc./…j/c/users/owner/desktop/panda3d-1.9.4/etc/…/models”)
Traceback (most recent call list):
File “”, line 29, in
LoanShark = Actor ('phase_3/models/char/suitB-mod.bam, {‘fingerwag’ : phase_5/models/char/suitB-finger-wag.bam})
File C:Users\Owner\Desktop\Panda3D-1.9.4\direct\actor\", line 280, in init
self.loadModel (models, copy = copy, okMissing = okMissing
File C:Users\Owner\Desktop\Panda3D-1.9.4\direct\actor\", line 1910, in loadModel
That’s not the whole thing, but can anyone help me with why it won’t work?

Panda3D will issue such an error if you passed a model filename that doesn’t exist. Make sure there is in fact a file called “phase_3.5/models/char/suitB-mod.bam” relative to the working directory.

The file does exist, but maybe I need to change the code a bit, as the phase_3.5 folder is in the bin folder of panda3d.

Panda won’t look for models in the “bin” directory by default. If you’d like to put your models there, you can add this to your PANDA_DIR/etc/Config.prc file:

model-path $THIS_PRC_DIR/../bin

Alternatively, move the phase_3.5 directory to the “models” directory.

I would do that, but the models folder is in the phase_3.5 folder.

Ah, nevermind. I see what you mean.

I did the alternative, and it still dosen’t work.


Please share the full path of the file you are trying to load.

It is in C://Users/Owner/Desktop/Panda3D-1.9.4/m … e_3.5/char i believe

So you’re trying to load this path:


Even though you say the actual path (relative to the models directory, which is in the model-path) is:


The problem seems clear, then. You’re simply passing the wrong path to the load function. Change the path you’re loading to the second one, or reorganise your directory tree to match the first one.

I tried that and it still dosen’t work. There is a seperate file called ‘models’ in phase_3.5