Am I stupid?

I find blender way to hard. It has such a bad interface that its impossible to do anything meaningful in it. So I use Google Sketch-up, and the GUI on it is so easy to use I finished modeling. I look at Sketch-Up and it only has two exports .dae and some google file. I though no problem because blender has a .dae import and an .egg export [thanks to chicken]. So when I import it into blender its just a big green box, and I can’t see anything else. I figure its okay seeing as it was a built in exporter, and I try to export the file to a .egg. Chicken throws back an error, no file selected. So I go back and [right click selects?] select the giant green box and try to convert again. Now nothing happens.

Am I stupid?

I don’t know about Blender and Chicken, but as of 1.7.0, Panda can load .dae files directly. There’s also a dae2egg program in the distribution.

Try viewing your dae file in pview. If it’s a big green box there too, then perhaps something about the dae file is wrong. :slight_smile:


Google tools export .dae models with transparency inverted. So you often need to manually invert the transparency if nothing shows up in Panda.

How can i get the dae2egg file working? whenever i run it it never wants to work

I have a shorcut that runs this

C:\Panda3D-1.7.0\bin\dae2egg.exe -O temp.dae

And the cmd opens then disspears too quickly for me to read what the error is.

Well, maybe I am stupid, I just dragged the .dae file onto dae2egg.exe and it worked fine. But where did the file go?

Run it from the command-line.

Well, maybe I am stupid, I just dragged the .dae file onto dae2egg.exe and it worked fine. But where did the file go?

[Double post?]

get used to the command line and run the tools from there. there’s no way around this

Command Lines are so clunky in windows :’(

No one has made a simple gui version of this?

I guess not.

Is there any reason why only half of my colors show up after my dae has been converted?

Blenders only useless if you’re too impatient to learn how to use it. Sketchup is nice, but very very limited, you cannot make player models, or UV map in sketchup.

What I do it I use Sketchup to make game maps, and Blender to make Players, objects, and everything else.

Blender also supports more formats, 2 of which can be loaded into the Panda3D engine (dae, and x) and has a plugin for egg.

IMO, its best to convert to egg, make sure it works, then convert to bam, becaue BAM is binary, therefore it loads faster.

But seriously learn how to use blender is really nice, once you learn how to use it, you’ll be amazed.