About packpand

I made a application ,when I used python main.py, then it works.
I packed it with packpanda. Then I installed it. but it cann’t work.
Bcz there isn’t in the commandline, so nothing output.
How to deal with it ?
I found the directory I installed there are:bin\direct\etc\game\modelcache and so on.
In game,there are what I wrote before. And I used python main.py(in game) ,it works.

Another question: how to hide the main window in panda after I called run() function? how to hide the window? I just want to get the screenshot about my model(and use the screenshot to make a shaped window in wxpython),but don’t want the window showing

  1. Had the same problem at school, you have to run it differnt cuase panda 3d not “installed” like it would be at home, think of it as a just your game + things it needs to run it.

So instead of using ppython main.py you would 1st set it to the “python folder” then call where the game is.

So lets say it was installed in the c: drive under Game

cd C:\Game\python 
ppython C:\Game\game\main.py
  1. Not sure how to do that.

I tried what u said.

The commandline said: there isn’t a main.pyc file.

How to handle it ?

Try again, the messages are:

C:>c:\filename\python\ppython c:\filename\game\main.py
DirectStart: Starting the game.
Warning: DirectNotify: category ‘Interval’ already exists
Known pipe types:
(all display modules loaded.)
:util(warning): Adjusting global clock’s real time by 2.86102e-006 seconds.
Traceback (most recent call last):
File “c:\filename\game\main.py”, line 1, in
import Pet
File “C:\filename\game\Pet.py”, line 3, in
import direct.directbase.DirectStart
File “C:\filename\direct\src\directbase\DirectStart.py”, line 4, in
File “C:\filename\direct\src\showbase\ShowBase.py”, line 376, in init
File “C:\filename\direct\src\showbase\ShowBase.py”, line 2259, in __doStartDir
self.startDirect(fWantDirect = fDirect, fWantTk = fTk, fWantWx = fWx)
File “C:\filename\direct\src\showbase\ShowBase.py”, line 2238, in startDirect
File “C:\filename\direct\src\showbase\ShowBase.py”, line 2233, in startTk
import TkGlobal
File “C:\filename\direct\src\showbase\TkGlobal.py”, line 8, in
import Pmw
ImportError: No module named Pmw

What happened?

Some how the modules are not getting imported, not sure why, hmmm

Try this maybe…idk

C:\filename\game\python\ppython.exe -E C:\filename\game\main.py

Enter as one big line*

If this doesn’t work then i’m not sure.


maybe that helps?

I used packpanda to bundle up a test project I am working/learning on, and ran into some probs when a friend tried to run it.

The installer completed, and all of the files were included and unpacked it into my friends c:/Test folder. When launched the program could not find pandac, or any of the dll’s. He copied all of the files into the projects root dir and it produced a window as if trying to launch, but could not, giving a path error of “could not find c:/intel/somefile”. This directory is in no part of the dependencies for my little 6mb test project, and my machine doesn’t have an /intel dir at all.

Is this due to some thing with the client computer’s pc per chance? I thought packpanda included all of the dependencies needed. Wasn’t packpanda supposed to link path to the files it packed? it couldnt see any of them until he put them in the root dir.

Which version of Panda did you use when you packed the game? Also, did it contain the “pandac” directory, after installing the game?

I used P3D 1.54, and it did pack the pandac directory, and unpack it to the client.

There were no errors on the pack, I’ll try to install it on a different local machine as well and see if i get the same results.

Oh, did that friend have a custom python version installed? Try removing that.