64-win7 panda3d and pdeply issue

I checked the file it a it is there. I think this has some thing to do with:

panda3d is installed here:
C:\Program Files (x86)\Panda3D\

Not in normal Program Files. Could this be an issue?

As for the pdeploy error, it’s a bug in 1.7.0 - you should download runtime.panda3d.org/pdeploy.p3d and place it in the bin directory.

And it is not related to the inability to run ‘panda3d’. That’s just because the runtime installer doesn’t add itself to the PATH (and there are reasons not to). Instead, pdeploy.exe reads the runtime installation directory from the registry.

Ok thanks!

I mean really? How hard is it to package this in the installer?

If you know about this obvious “BUG” and it requires 0 time to fix it - why not do it?
This is the second time I googled for missing *.p3d file when trying to package an application.
Shame on you! :slight_smile:

It’s already fixed. But we’re waiting for other fixes to come in before we release them all together with 1.7.1.