1.8.1 SDK Release

Very cool! Thank you!

Seams to work just fine. Good one.

But the search function for the 1.8.1 Python API reference seams broken.
For example searching for setHPR points to

http://www.panda3d.org/reference/1.8.1/python/classpanda3d_1_1core_1_1NodePath.php#a29c4e6dbeb0225706140f99e10f4f57e

when it should:

http://www.panda3d.org/reference/1.8.1/python/classpanda3d.core.NodePath.php#a29c4e6dbeb0225706140f99e10f4f57e

it gives “_1_1” where it should be just “.”

Great!
Thank you

Greate work!!!
I alway waiting for version for quantal !!!

Panda3D 1.8.1 is now on AUR for arch linux

Always great to see a new release. Congratulations!

I’m experiencing some problems with GLSL shaders, though, that didn’t happen on the dev builds that I’ve been using before.

Problem 1)

This error:

:task(error): Exception occurred in PythonTask igLoop
Process Process-1:
Traceback (most recent call last):
  File "/usr/lib/python2.7/multiprocessing/process.py", line 258, in _bootstrap
    self.run()
  File "/usr/lib/python2.7/multiprocessing/process.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "/home/coppertop/Development/gamedev/SDK/copperEd/backEnd.py", line 209, in __init__
    run()
  File "/usr/share/panda3d/direct/showbase/ShowBase.py", line 2921, in run
    self.taskMgr.run()
  File "/usr/share/panda3d/direct/task/Task.py", line 502, in run
    self.step()
  File "/usr/share/panda3d/direct/task/Task.py", line 460, in step
    self.mgr.poll()
  File "/usr/share/panda3d/direct/showbase/ShowBase.py", line 1846, in __igLoop
    self.graphicsEngine.renderFrame()
AssertionError: Shader input trans_model_to_clip_of_lightCam0 is not present.
 at line 466 of panda/src/pgraph/shaderAttrib.cxx

is caused by these lines:

uniform mat4 trans_model_to_clip_of_lightCam0;
(...)
void main() {
(...)
shadowTexcoord = myMat * trans_model_to_clip_of_lightCam0 * p3d_Vertex;
}

Note that “lightCam0” is correctly set as shader input pointing at a NodePath for a camera and no changes were made to this code since yesterday, when it worked – the only thing that changed was the Panda version.

If I remove these two references to trans_model_to_clip_of_lightCam0 it doesn’t crash, but (obviously) shadows don’t work and Problem 2 happens.

Problem 2)

A flood of this:

:display:gsg:glgsg(error): Active attribute p3d_MultiTexCoord0 is bound to location 1
:display:gsg:glgsg(error): Active attribute p3d_Vertex is bound to location 0
:display:gsg:glgsg(error): Active attribute p3d_Vertex is bound to location 0
:display:gsg:glgsg(error): Active attribute p3d_Binormal0 is bound to location 4
:display:gsg:glgsg(error): Active attribute p3d_MultiTexCoord0 is bound to location 1
:display:gsg:glgsg(error): Active attribute p3d_MultiTexCoord2 is bound to location 5
:display:gsg:glgsg(error): Active attribute p3d_Normal is bound to location 2
:display:gsg:glgsg(error): Active attribute p3d_Tangent0 is bound to location 3
:display:gsg:glgsg(error): Active attribute p3d_Vertex is bound to location 0
:display:gsg:glgsg(error): Active attribute p3d_Vertex is bound to location 0
:display:gsg:glgsg(error): Active attribute p3d_Binormal0 is bound to location 3
:display:gsg:glgsg(error): Active attribute p3d_MultiTexCoord0 is bound to location 4
:display:gsg:glgsg(error): Active attribute p3d_Normal is bound to location 1
:display:gsg:glgsg(error): Active attribute p3d_Tangent0 is bound to location 2
:display:gsg:glgsg(error): Active attribute p3d_Vertex is bound to location 0
:display:gsg:glgsg(error): Active attribute p3d_MultiTexCoord0 is bound to location 1
:display:gsg:glgsg(error): Active attribute p3d_Vertex is bound to location 0

when the game/editor starts. Despite that, the shaders work as expected, which is even more weird in a way :wink:.

Congratulations, and thank you very much! :slight_smile:

Great! Congratulations and thank you!

Thank you for the update but I would also like to mention wezu’s comment about the API being broken for 1.8.1. Looking up NodePath and clicking on any of the docs causes 404 errors or links not doing anything.

I know this isnt a big deal but I keep clicking the 1.8.1 docs and then having to backtrack to the 1.8 docs.

@coppertop:

  1. this is because the trans_ inputs were added on the 1.9 branch, not on the 1.8 branch. This is why the devel builds support it but not the 1.8.1 release.

  2. Oops. That probably should have been a debug message, not an error message. Not sure how that could have slipped past in my testing. I’ll check in a fix immediately, but in the meantime, you can set notify-level-glgsg to ‘fatal’ (although then you won’t see other errors either).

@wezu, hobbit: I’ll look into it.

@rdb

Ah, I thought they were also included in 1.8.1. My bad.

Hi rdb, just got around to installing this and encountered one issue. I have an external sound card that I can turn on and off. With 1.8.0 having the sound card off only produced a warning message, but in 1.8.1 it actually crashes unless I have the sound card on at all times. Here’s the error msg:

DirectStart: Starting the game.
Known pipe types:
  wglGraphicsPipe
(all display modules loaded.)
:audio(error): OpenALAudioManager: alcOpenDevice(NULL): ALC couldn't open device
:audio(error): OpenALAudioManager: No open device or context

Same issue on sound card here!

Please file an issue in the bug tracker.

Can you guys try removing OpenAL32.dll from C:/Panda3D-1.8.1/bin and then renaming soft_oal.dll to OpenAL32.dll, and see if that fixes the issue?

it doesn’t work for me.

Let’s move any discussion about the OpenAL crash to this thread to avoid fragmentation.

I currently maintain an Arch package for panda3d bundled with bullet and working audio. The issue is, does 1.8.1 still depend on old versions of ffmpeg (0.5) and the old bullet CVS? I can’t seem to find this information anywhere.

Thanks!

Panda doesn’t currently compile against the most recent version of ffmpeg, I’m afraid. I’m not sure about Bullet; I don’t think that there should be a problem with newer versions of Bullet, but enn0x would be the person to ask.

Thanks for this wonderful news.