1.6.2 released

Some of you already noticed it, but I thought I’d put up a notice for the rest of you.

This is mainly a bugfix release. Also fixes some bugs that
were accidentally introduced in 1.6.1.

  • Fixed a static-init issue in ptloader on Windows
  • Fixed texture scaling issue when using buffers
  • x2egg is no longer broken
  • Threading in OSX build fixed
  • Fixed issue with flickering colors in Shader Generator
  • Eggcacher now uses less RAM
  • Missing ‘models’ dirs in packpanda games fixed
  • Eggcacher step in Panda3D installer is now optional
  • Fixes broken shortcut links in Start Menu on Windows
  • Shader Generator now supports clip planes
  • Bug with combine modes in Shader Generator fixed
  • Fixed bug with Texture::make_copy()
  • Bug with Actor LOD fixed
  • Fixed bug with missing geometry in Collada converter
  • OdeUtil.collide instability fixed
  • OdeBody setData/getData methods exposed to Python

You might wonder: why are there no RPM builds. I’m working on that. You can download them here, for now:
download.opensuse.org/repositori … //Panda3D/

Finally I can import models… Thx m8!



Congrats on another release. Glad to see some of those fixes, especially as a fair few directly affect me:-D

/me thinks we are doing them a bit fast … people need time to catch up!

Well, I think it’s a good idea to release earlier and more often. Especially for bugfix releases.
This was also kind of an emergency release because 1.6.1 introduced some serious bugs.

The next release will be farther away, I think - either 1.6.3 or 1.7.0, depending on the number of bugs.

Yay, pview works again! Exporting models was annoying when that was broken. I’m impressed by the quick releases, don’t slow down too much :slight_smile:

Oh, and hello to the panda community.

Thanks for the new release pro-rsoft. No problems in win/lin so far, just in mac…again :frowning:

File "Tut-Asteroids.py", line 13, in <module>
    import direct.directbase.DirectStart
  File "Panda3D-tpl-rw/Panda3D/1.6.2/lib/direct/directbase/DirectStart.py", line 4, in <module>
  File "Panda3D-tpl-rw/Panda3D/1.6.2/lib/direct/showbase/ShowBase.py", line 229, in __init__
  File "Panda3D-tpl-rw/Panda3D/1.6.2/lib/direct/showbase/ShowBase.py", line 692, in openDefaultWindow
  File "Panda3D-tpl-rw/Panda3D/1.6.2/lib/direct/showbase/ShowBase.py", line 777, in openMainWindow
  File "Panda3D-tpl-rw/Panda3D/1.6.2/lib/direct/showbase/ShowBase.py", line 534, in openWindow
  File "Panda3D-tpl-rw/Panda3D/1.6.2/lib/direct/showbase/ShowBase.py", line 467, in makeDefaultPipe
  File "Panda3D-tpl-rw/Panda3D/1.6.2/lib/direct/directnotify/Notifier.py", line 130, in error
StandardError: No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.

Version 1.6.1 was working fine, I’ll revert back and check if it’s still working ok :wink:


Whatever the problem is it isn’t a global thing with OSX, because I just tested the asteroids demo and it runs fine for me. Do you only encounter the problem with that one demo, or is it with everything?

ADDITION: Also, what are your system specs? In particular, what videocard does your computer have?

Hmm, maybe the install somehow got corrupted? Try reinstalling.
Also, check the /Applications/Panda3D/1.6.2/etc/Config.prc file, and check if it says “load-display pandagl”. If it does, try switching to “tinydisplay” - does that work?

@Jhocking: it’s happening with every example :frowning:
@Pro-rsoft: I’ll try redownlaoding and reinstalling and tell you how it went :wink:

thanks for the prompt answers guys.


ps. The only different thing now is that I updated to 10.5.7. Jhocking, are you still on 10.5.6? Could it be that the upgrade screwed up something?

No, I am using Panda 1.6.2 on OSX 10.5.7 so that’s why I asked about your computer specs. Clearly the problem is in something that is different about your machine than mine, so we need to track down that difference.

Changing the video driver to:

load-display tinydisplay

worked, but it’s very slow (is this panda’s software renderer?) and I guess I won’t be able to run any of the fancy stuff. I guess it’s something with GL acceleration then, but other applications that depend on it are running fine (like blender). :frowning:

I’ll dig a bit more to see what I can find.
System specs:
Processor: Intel Core2duo E8400 3.0 Ghz
Video: Nvidia 8800GT 512 Mb
Ram: 4 GB ddr2 800 mhz

Hmm. Does the file libpandagl.dylib exist in the lib/ dir?
What is the full output of running pview?

ahhhh, interesting approach Pro-rsoft :wink:
“libpandagl.dylib” is there, but running “pview” gives me this output:

 ~afecelis$ pview
:display(warning): Unable to load: dlopen(/Applications/Panda3D/1.6.2/lib/libpandagl.dylib, 6): Symbol not found: __glapi_Context
  Referenced from: /usr/X11/lib/libOSMesa.4.dylib
  Expected in: /usr/X11/lib/libGL.1.dylib

Known pipe types:
(all display modules loaded.)
No graphics pipe is available!
Your Config.prc file must name at least one valid panda display
library via load-display or aux-display.

So it seems to be a problem with paths in my X11 and MesaGl drivers…mmmmm. I’ll try to find info on this regard, but I think a symlink will fix this (unfortunately, I dunno how to do it properly, lol). I also installed the latest version of Xquartz (X11) for 10.5.7 to be able to run applications like Gimp and Inkscape. Verison from here:

Does this build work?

Is that he same version as the official release? or does it have a modification? :wink:

I downloaded it and I still get the same errors.

Thanks for the help :smiley:

i had the same error you have.
have you modified the config.prc file?
if so, you need to use another editor.

and what happens if you put

from pandac.PandaModules import *
loadPrcFileData("", " load-display pandagl")

at the start of a programm.



Nope, it looks like it tries to load libpandagl, but there’s a linker error.

What version of OSX are you using, afecelis? Did you have the problem with older versions of OSX / Panda?

thanks pro-rsoft for keep trying :wink:
I had 10.5.6 installed and upgraded to 10.5.7, and nope, I didn’t have this problem on the prior version (besides the small issues reported and fixed by you here in 1.6.0-1.6.1). :wink:

As a side note, just to make sure my GL acceleration wasn’t crippled somehow I tried Jmonkey 3d engine (totally java-crossover compatible engine) and Irrlicht and all of the GL advanced stuff ran fine. It’s Only Panda3d which is not being able to load the GL driver specified in the .prc file.


just giving some input…