1.5.0 Release! (partay!)

Huzzahs all around, 1.5.0 has been released! Good job Josh and everyone else who helped push it along!


Josh, the front page needs the big download button back.

Meh, Sorry, didn’t get finished with PGMM in time…

Hey, that’s not a problem at all… just let me know when it’s ready, and we’ll make a 1.5.1 release.

lets the spamming begin!
gamedev.net/community/forums … _id=487029
wiki.python.org/moin/PythonGameLibraries (it would be nice to get a page on the python wiki but i cant find how)

I am trying to stress on the python/c++ part … Its kinda not mentioned at the front of the site though but i think it is panda3d’s most powerful feature.

Two people that replied were unhappy that there is no mac.

Somebody to make a mac distro for 1.5.0 would be indeed good… and quick. Now we’re advertising it ppl get lots of questions about mac support.

devmaster.net/forums/showthr … #post56083
/me googles for other game dev websites…

EDIT: Oh Josh Yelon, I just noticed that Roaming Ralph in C++ is not included… is there a chance you can include it in the next version so C++ users will at least have something except just pview and hello world?

I could conceivably add “roaming ralph in C++” in 1.5.1.

I got a updated binary read, however i have excluded openal audio. It requires a lot of patching and it’s already late :slight_smile:, last but not least i think it’s still not working correctly on linux/osx platforms (correct me if im wrong).

So currently it’s fmod only.

I have not tested this package at all. I will try to do that tomorrow.

Still only intel OSX 10.4.x & 10.5.x

This time i left some more stuff in the package, which could be removed:
Contents/Ressources/panda/etc/*.in files

Also pandatools are now included, which werent before.

Have fun (if it works :wink:

(filesize is around 61.1MB, if you read this message to early im still uploading)


Hypnos: when you build that, are you using ppremake or makepanda?

The reason I ask is: if makepanda were working under Mac OSX, I could fairly easily include Mac OSX support in the standard distro.

Panda 1.5.0…!!! Well, let me try to convince our dept. to use this in our course. If I have any question, I will contact Prof. Yelon.


Kind Regards,

I’d be happy to help if I can.

PS. If you really want to convince your department, point to this feature:

Just Works, Right out of the Box
No-hassle install:

    * Convenient installer package for Windows
    * Only one external dependency: working graphics driver
    * Sample programs run right out of Start Menu
    * No compilation step needed
    * Installers (rpm & deb) for Linux too 

Speaking as one, I can say: the one thing that a professor hates it’s dealing with software that’s hard to get running.



I will try to create a simple game template for the upcoming game workshop in august (not finalised yet), then I can present the outcomes (rapid-prototyping) and “Works right out the box + tons of features” to my supervisor & dept.

You are correct, professors & lecturers don’t like software that takes forever to get it running.

Any issues comes up, I’ll get in touch with you.

Thank you kindly,
we are at: ics.mq.edu.au/~isvr/index.htm

Hi Josh,

To compile panda3d i still rely on ppremake. Last time i tried makepanda had some sys.platform but no darwin option.

I have also had some compilation issues. I have included a build log/howto in the dmg, but it only describes the steps for a system already setup with all required library’s. After compilation it’s also required to modify the lib-linkings, which afaik only can be done under osx (requires otool).

But i’d be pleased to help setting up a automatic build.

BTW, the new version works with python2.5 ?

oops ! the release notes say :

  • Now compiled for Python 2.5

I am a happy camper !

makepanda doesn’t have a darwin option - it won’t have one until somebody writes one. :slight_smile: I can’t be the guy to write it, since I don’t know macs at all.

If i get the time, ill try to get makepanda osx capable. (not very likely anytime soon)

Btw. My OSX panda build is still compiled against 2.4. Im not sure if i can fix that soon.

Could that OSX build maybe included on the download page?

Btw. the API reference is still at version 1.4.2…

If it’s included have a note:

Intel Macs only.
10.5 tested, 10.4 not tested but should work.

Maybe with links to the descriptions how to install it and how to customize it.
Install: discourse.panda3d.org/viewtopic.php?t=3592
Customize: discourse.panda3d.org/viewtopic.php?t=3402

(i have not tested the install procedure, but i think that should work fine)

Could some 10.4 user verify that it’s working?

we are in Italy!
mambro.it/index.php/2008/03/ … /#more-973

I am working on makepanda under Leopard, with a fair amount of success. The configuration is only very slightly different from the linux configuration.

So far the compilation succeeds all the way to the interrogate stage, where it chokes on a couple of C99 system headers. I am not familiar with interrogate, so I haven’t been able to retarget it at the 10.5 SDK (which uses a simpler version of these headers) instead of the current system - does anyone here have a command for that?